Lua 5.2 disabled


#1

Hi,
I see that Lua 5.2 is disabled in the compiler script and only LuaJIT is available. This contradicts The Halite III Server Environment, is this an issue with both interpreters having the same file extension? Is there any chance to add Lua 5.3 to the server environment with a custom extension, e.g. .lua53, or some other mechanism of disambiguation?


#2

Yes, looks like we have Lua installed but not available through the compiler. Changing the extension would work - it’s what we do for PyPy - and if you would like to submit a PR or file an issue for this, please feel free!


#3

Thank you, I opened an issue.


#4

Lua 5.3 is now available. Submit a bot MyBot.lua53 to compile with Lua 5.3. Yay! :last_quarter_moon_with_face: