Errors when running Halite III locally


When I run the Windows x86 Java version located at the downloads page, it gives me an error saying, "
Turn 1
error: communication error with bot: Problem writing to pipe, errno was: 0 (No error)
Last input received was:

I get this error when I run the Java version (Windows x86) download.
I’ve tried restarting my computer, and I haven’t even changed the code that was provided in this download. My computer is running Windows 10 on a 64-bit Operating system, Intel Core i7-8700. Is the issue that it’s x86 running on a x64? If so, are there are versions that would not cause this? (I’ve tried running the AMD64 version but it just gets stuck in the console and never finished running, probably because I don’t have an AMD processor.) Thank you!


AMD64 is just another name for x64, so it should work for you.

When you say stuck in the console - is there anything it prints out?

Are you able to run java MyBot from the console (from the same directory as run_game.bat)?


The AMD64 version gives me the same issue, I’ve tried running it from console and it’s still not working. In my school, we have MAC computers and it worked there, so I don’t think the error is in my code. It just says that “Communication failed” in the command prompt and in the logs. It also happens when I run it in different languages, so something in my PC is messed up and idk what is causing the issue,


What do you mean by not working? What happens when you run java MyBot?


If I run java MyBot, it hangs indefinitely (probably because of the infinite loop used to wait for the input from the game), I did a little bit of things and when I run it in console it gives me this,
[info] [P0] Launching with command java MyBot
[info] [P1] Launching with command java MyBot
[info] [P0] Initializing player
[info] [P1] Initializing player
[info] [P0] Initialized player ‘java’ is not recognized as an
[info] [P1] Initialized player ‘java’ is not recognized as an
[info] Player initialization complete
[error] [1] [P0] Communication failed
[error] [1] [P1] Communication failed
[error] [1] [P1] Last input received was:
[error] [1] [P1]
[error] [1] [P1] operable program or batch file.
[error] [1] [P0] Last input received was:
[error] [1] [P0]
[error] [1] [P0] operable program or batch file.
[warn] [1] [P0] Killing player
[warn] [1] [P1] Killing player
at the end of the log it says,
[info] Player 0, ‘‘java’ is not recognized as an’, was rank 1 with 0 halite
[info] Player 1, ‘‘java’ is not recognized as an’, was rank 2 with 0 halite
If that’s important… Thank you for the help
Okay I think I may have figuired it out, when I run the regular “java” command, nothing happens and to run java I have to actually navigate to the java folder. I think it must have installed odd or something like that to where I can’t run it from console, I’m going to look into how to fix this and hopefully this will fix my errors. (I do have JDK installed, but can’t run the commands without going to the JDK folder)


I FINALLY GOT IT TO WORK!!! Turns out since I reinstalled java, the environment variables were never re-updated so java couldn’t be run from the command line. Thank you for you help and bringing me closer to realizing how silly of a mistake it was. Good luck coding!!


Glad you figured it out!